$re = '/\\\\[^\\\\]+(?=\.exe)/m';
$str = 'R:\\soft\\port\\application\\123 - pic convert [5791G]\\123 - pic convert [5791G].exe
R:\\soft\\port\\application\\Jane\'s homemade recipe [981GF]\\Jane\'s homemade recipe [981GF].exe
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;