re = /\\[^\\]+(?=\.exe)/m
str = 'R:\\soft\\port\\application\\123 - pic convert [5791G]\\123 - pic convert [5791G].exe
R:\\soft\\port\\application\\Jane\'s homemade recipe [981GF]\\Jane\'s homemade recipe [981GF].exe
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result