package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+@\S+\.edu$`)
var str = `My email address is malan@harvard.edu
malan@harvard.edu
malan@harvard.edu asdsad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}