$re = '/^\S+@\S+\.edu$/m';
$str = 'My email address is malan@harvard.edu
malan@harvard.edu
malan@harvard.edu asdsad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);