re = /^\S+@\S+\.edu$/m
str = 'My email address is malan@harvard.edu
malan@harvard.edu
malan@harvard.edu asdsad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end