#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z]+-[a-z]+"
Local $sString = "oikos_kreos-drape__kr115+an08" & @CRLF & _
"oikos_kreos-drape__kr115-an08" & @CRLF & _
"oikos_kreos-drape__kr115" & @CRLF & _
"oikos_kreos-drape" & @CRLF & _
"kreos-drape"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")