using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]+-[a-z]+";
string input = @"oikos_kreos-drape__kr115+an08
oikos_kreos-drape__kr115-an08
oikos_kreos-drape__kr115
oikos_kreos-drape
kreos-drape";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}