$re = '/[a-z]+-[a-z]+/m';
$str = 'oikos_kreos-drape__kr115+an08
oikos_kreos-drape__kr115-an08
oikos_kreos-drape__kr115
oikos_kreos-drape
kreos-drape';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);