const regex = /(\d*)(D\d*)((?:[+*-](?:\d+|\([A-Z]*\)))*)(?:\+(D\d*))?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)(D\\d*)((?:[+*-](?:\\d+|\\([A-Z]*\\)))*)(?:\\+(D\\d*))?', 'gi')
const str = `1D10*10
D10+20
D10+D10
D10+(Strength)
D10+20+1*2+(Strength)+D10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}