import re
regex = re.compile(r"(\d*)(D\d*)((?:[+*-](?:\d+|\([A-Z]*\)))*)(?:\+(D\d*))?", flags=re.IGNORECASE)
test_str = ("1D10*10\n"
"D10+20\n"
"D10+D10\n"
"D10+(Strength)\n"
"D10+20+1*2+(Strength)+D10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")