re = /(\d*)(D\d*)((?:[+*-](?:\d+|\([A-Z]*\)))*)(?:\+(D\d*))?/i
str = '1D10*10
D10+20
D10+D10
D10+(Strength)
D10+20+1*2+(Strength)+D10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end