#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9\h/\\?:().,'+-]+$"
Local $sString = "slash/" & @CRLF & _
"minus-" & @CRLF & _
"questionmark?" & @CRLF & _
"twopoint:" & @CRLF & _
"openparenthesis(" & @CRLF & _
"closeparenthesis)" & @CRLF & _
"point." & @CRLF & _
"comma," & @CRLF & _
"simplequote'" & @CRLF & _
"plus+" & @CRLF & _
"SPACE " & @CRLF & _
"azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN " & @CRLF & _
"azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , ' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN" & @CRLF & _
"azertyuiopqsdfgh\\jklmwxcvbn/ - ? : ( ) . , ' +" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")