using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+\s*(.*?)\s";
string input = @"<insert_randomletters>[?] I want this string.Reduced<insert_randomletters>
<insert_randomletters>[?] I want this string.Reduced<insert_randomletters>
<insert_randomletters>[?]I want this string.Reduced<insert_randomletters>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}