re = /\+\s*(.*?)\s/
str = '<insert_randomletters>[?] I want this string.Reduced<insert_randomletters>
<insert_randomletters>[?] I want this string.Reduced<insert_randomletters>
<insert_randomletters>[?]I want this string.Reduced<insert_randomletters>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end