$re = '/\+\s*(.*?)\s/';
$str = '<insert_randomletters>[?] I want this string.Reduced<insert_randomletters>
<insert_randomletters>[?] I want this string.Reduced<insert_randomletters>
<insert_randomletters>[?]I want this string.Reduced<insert_randomletters>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);