use strict;
my $str = ' мм. см. лт.
';
my $regex = qr/ (мм|см|лт)\K\./p;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";