import Foundation
let pattern = #" (мм|см|лт)\K\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
мм. см. лт.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)