#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=1*(?:01*01*)*$)0*(?:10*10*)*$"
Local $sString = "100001" & @CRLF & _
"10001" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"00" & @CRLF & _
"1001" & @CRLF & _
"0101" & @CRLF & _
"011" & @CRLF & _
"101" & @CRLF & _
"1010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")