$re = '/^(?=1*(?:01*01*)*$)0*(?:10*10*)*$/im';
$str = '100001
10001
1
11
00
1001
0101
011
101
1010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);