re = /^(?=1*(?:01*01*)*$)0*(?:10*10*)*$/im
str = '100001
10001
1
11
00
1001
0101
011
101
1010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end