import re
regex = re.compile(r"\s*[^ /]+/[^ /]+", flags=re.MULTILINE)
test_str = "A disgrace to his profession. pic.twitter.com/ZH08wej40K In a major victory for religious liberty, the Admin. has eviscerated institution continuing this path. goo.gl/YmNELW nothing like the admin. proposal: tinyurl.com/ydyzzlkk"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)