#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/((\w+)\.)?(\w+)\.(\w{3})$"
Local $sString = "c:/my_project/sources/hr.manage_employees.pks" & @CRLF & _
"c:/my_project/sources/hr.manage_employees.pkb" & @CRLF & _
"c:/my_project/sources/hr.employee_typ.tps" & @CRLF & _
"c:/my_project/sources/hr.employee_typ.tpb" & @CRLF & _
"c:/my_project/sources/hotel.manage_rooms.pks" & @CRLF & _
"c:/my_project/sources/hotel.manage_rooms.pkb" & @CRLF & _
"c:/my_project/tests/hr.test_manage_employees.pks" & @CRLF & _
"c:/my_project/tests/hr.test_manage_employees.pkb" & @CRLF & _
"c:/my_project/tests/hotel.test_manage_rooms.pks" & @CRLF & _
"c:/my_project/tests/hotel.test_manage_rooms.pkb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")