re = /\/((\w+)\.)?(\w+)\.(\w{3})$/m
str = 'c:/my_project/sources/hr.manage_employees.pks
c:/my_project/sources/hr.manage_employees.pkb
c:/my_project/sources/hr.employee_typ.tps
c:/my_project/sources/hr.employee_typ.tpb
c:/my_project/sources/hotel.manage_rooms.pks
c:/my_project/sources/hotel.manage_rooms.pkb
c:/my_project/tests/hr.test_manage_employees.pks
c:/my_project/tests/hr.test_manage_employees.pkb
c:/my_project/tests/hotel.test_manage_rooms.pks
c:/my_project/tests/hotel.test_manage_rooms.pkb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end