use strict;
my $str = 'c:/my_project/sources/hr.manage_employees.pks
c:/my_project/sources/hr.manage_employees.pkb
c:/my_project/sources/hr.employee_typ.tps
c:/my_project/sources/hr.employee_typ.tpb
c:/my_project/sources/hotel.manage_rooms.pks
c:/my_project/sources/hotel.manage_rooms.pkb
c:/my_project/tests/hr.test_manage_employees.pks
c:/my_project/tests/hr.test_manage_employees.pkb
c:/my_project/tests/hotel.test_manage_rooms.pks
c:/my_project/tests/hotel.test_manage_rooms.pkb';
my $regex = qr@/((\w+)\.)?(\w+)\.(\w{3})$@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}