package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S*) (.*) (\d+\/\d+.*)`)
var str = `Michelin Alpin 3 185/70 R14 GRNX --> [Michelin] [Alpin 3] [185/70 R14 GRNX]
Continental VancoWinter 2 225/75 R16C C M+S --> [Continental] [VancoWinter 2] [225/75 R16C C M+S]
Kleber VIAXER 175/70 R13 82T --> [Kleber] [VIAXER] [175/70 R13 82T]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}