import Foundation
let pattern = #"^(\S*) (.*) (\d+\/\d+.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Michelin Alpin 3 185/70 R14 GRNX --> [Michelin] [Alpin 3] [185/70 R14 GRNX]
Continental VancoWinter 2 225/75 R16C C M+S --> [Continental] [VancoWinter 2] [225/75 R16C C M+S]
Kleber VIAXER 175/70 R13 82T --> [Kleber] [VIAXER] [175/70 R13 82T]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)