using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!.*?shows).)*|^((?!.*?Dealt).)*";
string input = @"foo shows bar
foo Dealt bar
line without either one
line with both shows Dealt ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}