re = /^((?!.*?shows).)*|^((?!.*?Dealt).)*/m
str = 'foo shows bar
foo Dealt bar
line without either one
line with both shows Dealt '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end