re = /^"([^"]+)" (.*)/m
str = '"C:\\Program Files (x86)\\Mozilla Firefox\\firefox.exe" -osint -url "about:blank"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end