use strict;
my $str = 'Hello there, {{name}}
Hello there, {{ name }}
Hello there, {{ name }}';
my $regex = qr/{{\s*([^{}]+\S)\s*}}/mp;
my $subst = 'General Kenobi';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";