$re = '/{{\s*([^{}]+\S)\s*}}/m';
$str = 'Hello there, {{name}}
Hello there, {{ name }}
Hello there, {{ name }}';
$subst = "General Kenobi";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;