import re
regex = re.compile(r"{{\s*([^{}]+\S)\s*}}", flags=re.MULTILINE)
test_str = ("Hello there, {{name}}\n"
"Hello there, {{ name }}\n"
"Hello there, {{ name }}")
subst = "General Kenobi"
result = regex.sub(subst, test_str)
if result:
print(result)