using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<date>[A-Za-z]+\s+\d{1,2}\s+\d{4})\s+(?<hours>\d+(?:\.\d+)?)\s+hrs";
string input = @"Nov 23 2021 10 hrs
Nov 24 2021 8.5 hrs
Nov 27 2021 8.75 hrs
Dec 3 2021 10.25 hrs";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}