use strict;
my $str = 'Nov 23 2021 10 hrs
Nov 24 2021 8.5 hrs
Nov 27 2021 8.75 hrs
Dec 3 2021 10.25 hrs';
my $regex = qr/(?<date>[A-Za-z]+\s+\d{1,2}\s+\d{4})\s+(?<hours>\d+(?:\.\d+)?)\s+hrs/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}