const regex = /(?<date>[A-Za-z]+\s+\d{1,2}\s+\d{4})\s+(?<hours>\d+(?:\.\d+)?)\s+hrs/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<date>[A-Za-z]+\\s+\\d{1,2}\\s+\\d{4})\\s+(?<hours>\\d+(?:\\.\\d+)?)\\s+hrs', 'g')
const str = `Nov 23 2021 10 hrs
Nov 24 2021 8.5 hrs
Nov 27 2021 8.75 hrs
Dec 3 2021 10.25 hrs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}