const regex = new RegExp('\\^((?P<action>[A-Z])(?P<num>\\d+)?)+', 'gm')
const str = `: label_msg
text "^B3F2 Cut color 1 text from color 3 block"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}