// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\^((?P<action>[A-Z])(?P<num>\d+)?)+").unwrap();
let string = ": label_msg
text \"^B3F2 Cut color 1 text from color 3 block\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}