$re = '/\^((?P<action>[A-Z])(?P<num>\d+)?)+/m';
$str = ': label_msg
text "^B3F2 Cut color 1 text from color 3 block"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);