$re = '/\bof the\b(*SKIP)(?!)|\bthe\b/m';
$str = 'time of the day word of the day time the day';
$subst = "of the";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;