# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?<!\bof\s{1,100})the\b/of the/gm;t' <<< "time of the day word of the day time the day"