import Foundation
let pattern = #"\b(?<!\bof\s{1,100})the\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"time of the day word of the day time the day"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"of the"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)