const regex = new RegExp('\\b(?<!\\bof\\s{1,100})the\\b', 'gm')
const str = `time of the day word of the day time the day`;
const subst = `of the`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);