import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=='Security status'>)\\s*(|-)\\d+(|\\.\\d+)\\s*(?=\\<)";
final String string = "<url=showinfo:5//30042715 alt='Current Solar System'>Trossere</url></b> <color=0xff4cffccL><hint='Security status'>0.9</hint>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}