const regex = /(?<=='Security status'>)\s*(|-)\d+(|\.\d+)\s*(?=\<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<==\'Security status\'>)\\s*(|-)\\d+(|\\.\\d+)\\s*(?=\\<)', 'gm')
const str = `<url=showinfo:5//30042715 alt='Current Solar System'>Trossere</url></b> <color=0xff4cffccL><hint='Security status'>0.9</hint>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}