import re
regex = re.compile(r"(?<=='Security status'>)\s*(|-)\d+(|\.\d+)\s*(?=\<)", flags=re.MULTILINE)
test_str = "<url=showinfo:5//30042715 alt='Current Solar System'>Trossere</url></b> <color=0xff4cffccL><hint='Security status'>0.9</hint>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")