#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+[\s\-\(\)0-9]+)$"
Local $sString = "Карта Сбербанк - 5469550021126526" & @CRLF & _
"Оплата Яндекс деньги :+7(903)888-88-88" & @CRLF & _
"Номер кошелька: 41001194625877" & @CRLF & _
"Киви Кошелек - +79119068771" & @CRLF & _
"Кошелек - +380119068771" & @CRLF & _
"Тел +972 54 77 22 765" & @CRLF & _
"Москва. 31.03.2018г." & @CRLF & _
"Зароботок 3000$" & @CRLF & _
"+7-906-107-97-10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")