// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\+[\s\-\(\)0-9]+)$").unwrap();
let string = "Карта Сбербанк - 5469550021126526
Оплата Яндекс деньги :+7(903)888-88-88
Номер кошелька: 41001194625877
Киви Кошелек - +79119068771
Кошелек - +380119068771
Тел +972 54 77 22 765
Москва. 31.03.2018г.
Зароботок 3000$
+7-906-107-97-10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}