import Foundation
let pattern = #"(\+[\s\-\(\)0-9]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Карта Сбербанк - 5469550021126526
Оплата Яндекс деньги :+7(903)888-88-88
Номер кошелька: 41001194625877
Киви Кошелек - +79119068771
Кошелек - +380119068771
Тел +972 54 77 22 765
Москва. 31.03.2018г.
Зароботок 3000$
+7-906-107-97-10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)