#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*\/{2}.*)[\w?#.,]+|^(?:(?!\/{2}))[\w?#.,]+"
Local $sString = "//comment" & @CRLF & _
"code more code code?code //comment" & @CRLF & _
"" & @CRLF & _
"it doesn’t matter if http://doesn´t work.." & @CRLF & _
"fasd fdds" & @CRLF & _
"asdsd asdasdas hede " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")