$re = '/(?=.*\/{2}.*)[\w?#.,]+|^(?:(?!\/{2}))[\w?#.,]+/m';
$str = '//comment
code more code code?code //comment
it doesn’t matter if http://doesn´t work..
fasd fdds
asdsd asdasdas hede
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);